BillBelew.com
BloggingSocial MediaTwitter

Quick issue/problem with Twitter2612

Member FrugalTravelsNepal private msg quote post Address this user
When I post a tweet the snippet from the blog post doesn't show up. At first, I thought it was Bitly and twitter is playing games with them like they did to Linkis so I went to google and used their shortener. It still doesn't show the picture or intro. Even if someone retweets it there is still no snippet.

What am I doing wrong?

Here's my latest tweet that has no pic.

The worst thing about #NGO /#nonprofit is asking for money. No need to give us money.@KayGarnay4Nepal #humanitarian
Post 1 • IP   flag post
Student TParker private msg quote post Address this user
I get the snippet and image when I use Buffer to schedule a tweet of the blog, but not when I use the social share bar from the blog. Are there settings available for your share bar?


Post 2 • IP   flag post
Member FrugalTravelsNepal private msg quote post Address this user
I don't know if there is a button or not, but I think I should just use Buffer instead. I even tried google and it didn't give me the image.

Thanks, big help!
Post 3 • IP   flag post
Top Contributor Steve private msg quote post Address this user
Chances are it is nothing to do with the link you are sharing... you need to have Open Graph and Twitter Cards protocol enabled on your website... this allows social media to easily tell what is what on your site and display it accordingly....

Here is a link to Twitter which allows you to validate your website / URL
Post 4 • IP   flag post
Member FrugalTravelsNepal private msg quote post Address this user
Thanks Steve. It sounds good but this is what I get.

I put in the link like this: http://frugaltravelsnepal.blogspot.com/2017/06/sometimes-you-can-help-more-if-you-dont.html

I get this:


The card for your website will look a little something like this!
Unable to render Card preview

Then in the box below:

INFO: Page fetched successfully
INFO: 9 metatags were found
ERROR: No card found (Card error)
Post 5 • IP   flag post
Top Contributor Steve private msg quote post Address this user
That means you don't have Twitter Cards setup on your website... suggest you search blogspot for info on how to do this... until you have it setup you're never going to get it working and given that you aren't using WP and I've never used that platform... you're on your own

Try entering the URL of one of my blog posts and you'll see the difference... same tool.
Post 6 • IP   flag post
Teacher Rev private msg quote post Address this user
@FrugalTravelsNepal

If you were using WordPress -- and this is just one more reason why you should be -- and if you had the Yoast SEO plugin installed, you would have support for Twitter Cards.
Post 7 • IP   flag post
Student TParker private msg quote post Address this user
Ah well, at least Buffer takes care of it. : )

I am a WordPress user so can't advise on other platforms.
Post 8 • IP   flag post
Member FrugalTravelsNepal private msg quote post Address this user
Funny, but the reason I stay on Google is that they SEO their own first so I think I get a bit of a bump. I really don't like the platform because it errors a lot when I try to upload a picture. I've been trying to post elsewhere, too.

So, I finally got 8,500 followers after a month or more of having 8,490 or so. They just wouldn't let the followers increase. Even Twiends only lets me follow 13 people before they put the warning on.
Post 9 • IP   flag post
29147 9 9
Log in or sign up to compose a reply.
destitute